The Canadian Guitar Forum banner

1 - 20 of 23 Posts

·
Premium Member
Joined
·
575 Posts
Discussion Starter #1
I have a 1980 mesa mark IIb That does not switch channels using the foot switch. The channels change just fine using the push pull knob, but for some reason the foot switch that does not switch channels using the foot switch. The channels change just fine using the push pull knob, but for some reason the foot switch doesn’t work.

I have tested the foot switch and it tests fine. I’ve used different cables and they’re all fine.

Any ideas as to where I should start looking?
 

·
Registered
Joined
·
2,604 Posts
I have a 1980 mesa mark IIb That does not switch channels using the foot switch. The channels change just fine using the push pull knob, but for some reason the foot switch that does not switch channels using the foot switch. The channels change just fine using the push pull knob, but for some reason the foot switch doesn’t work.

I have tested the foot switch and it tests fine. I’ve used different cables and they’re all fine.

Any ideas as to where I should start looking?
Pictures ?

Sent from my SM-G935W8 using Tapatalk
 

·
Premium Member
Joined
·
4,030 Posts
I think all five are supposed to be pushed in. Also, make sure you are using a mono cable for the switch, not Stereo.
 

·
Premium Member
Joined
·
4,030 Posts
In the manual it also says make sure all five switches are pushed in. I think the idea being that the pull switches aren’t required eg. treble shift is automatically engaged in lead mode, etc. Now I have a Mk III, so you obviously know more than I do about the IIB.:)
 

·
Registered
Joined
·
2,604 Posts
In the manual it also says make sure all five switches are pushed in. I think the idea being that the pull switches aren’t required eg. treble shift is automatically engaged in lead mode, etc. Now I have a Mk III, so you obviously know more than I do about the IIB.:)
O ok lol i do agree with the cable .ive heard that for cabnets to heads and stuff

Sent from my SM-G935W8 using Tapatalk
 

·
Premium Member
Joined
·
575 Posts
Discussion Starter #18
No, silence from the amp. Stuck on clean.

But yeah, I’m able to use the push/pull to change channels no problem.
 
1 - 20 of 23 Posts
Top