The Canadian Guitar Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello everyone,

This is my very first post on the forum, I am wondering if anyone has come across this problem and has any solutions in mind:

My Line6 DL4 recently started making a crackling sound when I push the tap tempo switch. Probably wear and tear as it wasn't a problem before. The worst part is the crackling blends into the sound and delays, making it really annoying.

Any ideas / solutions? I have zero experience modding pedals, just wondering if it's something I can fix myself or if I need to take it to get repaired.

Thanks for the help!
 

·
Premium Member
Joined
·
25,139 Posts
One tends to see complaints from some L6 users about the switches they use on many of their pedals. I mention this not to diss their products, but to suggest it comes up often enough that pretty much any authorized L6 repair center will likely have replacements. A quick search notes that Long & McQuade on Steeles is likely the closest such center to you.
 

·
Registered
Joined
·
12,106 Posts
It's odd the sound is making it into the delay signal path, makes me wonder if the problem is more than the switch itself. I'm not familiar with the circuit design though so don't take my word for it. If I remember correctly those switches are just small tactile style mounted right to the PCB and they are prone to failure with this type of use. I would suggest spraying some contact cleaner into it as a possible short term fix but you'd have to take the pedal apart as the actual switch is deep under the foot button portion and covered by a boot of sorts. My suggestion would be to find someone who can replace the switches with something that can take the abuse a bit better. I know Dan Rasp (drasp) mods were very popular for a while with the DL4 and a lot of pedal hobby guys were doing them. You could look someone like that up or try and touch base with Dan himself.
 
1 - 3 of 3 Posts
Top