The Canadian Guitar Forum banner

1 - 10 of 10 Posts
P

·
Guest
Joined
·
0 Posts
Discussion Starter #1
My PS-6 started cycling on/off then off for good. I opened it up and nothing obvious...

Anything come to mind?
 
P

·
Guest
Joined
·
0 Posts
Discussion Starter #3
mhammer may have an idea, he will hopefully chime in, maybe it’s the switch
It was sort of a digitally on off on off them DOA.

Note: I bought the pedal used. When I opened it up last night a grounding washer fell out. One of the jacks was missing it. I put it on the jack, but the pedal is still DOA. I am not sure where it was, or if it was shorting out the board somewhere... I also don't know if it was like that from the factory or if the guy I bought it from forgot it. If the guy I bought it from left it there, why? Was there an issue? I took it off my board some time ago, and partly because I was having board issues and suspected it might have issues.
 

·
Premium Member
Joined
·
3,210 Posts
Where are you?

The switches and DC input jacks are a weak spot on these but the 'cycling on and off' makes me think it's more serious than that (the buffered bypass switching looks likely and I don't wanna mess with that personally).

@mhammer is in Ottawa; if you're in TO I can rec some other guys.
 
P

·
Guest
Joined
·
0 Posts
Discussion Starter #7
Where are you?

The switches and DC input jacks are a weak spot on these but the 'cycling on and off' makes me think it's more serious than that (the buffered bypass switching looks likely and I don't wanna mess with that personally).

@mhammer is in Ottawa; if you're in TO I can rec some other guys.
Ottawa...
 

·
Registered
Joined
·
345 Posts
P

·
Guest
Joined
·
0 Posts
Discussion Starter #9
I would guess with a new one costing $200 at L&M non warranty repairs are probably not cost effective...
 
1 - 10 of 10 Posts
Top